Issues accessing "CHMS" from within Tithely Dashboard
Incident Report for Tithe.ly ChMS
Resolved
This issue has been fully resolved and we have tested it to confirm full and expected functionality.
Posted Jun 10, 2022 - 11:26 PDT
Identified
We are investigating an issue where customers are receiving an error when attempting to click into "ChMS" from their Tithely Dashboard. The error states that "There was a problem grabbing your ChMS domain. Please try again"

Our Engineering team is aware of the cause of this and is working to resolve the issue now. Currently customers can access their Elvanto ChMS account direct through their Elvanto URL until this issue is resolved.
Posted Jun 10, 2022 - 10:38 PDT